The network design is as follows:
In this configuration the network 172.31.1.0/30 is a point to point link with using VLAN tag 302. The extreme configuration for this with the port/interface on the Extreme side being 1:1 (first port in the first slot) would be
create vlan p2pToCisco
configure vlan p2pToCisco tag 302
configure vlan p2pToCisco add ports 1:1 tagged
configure vlan p2pToCisco ipaddress 172.31.1.2 255.255.255.252
The following commands configure ospf on the Extreme switch assigning it to area 0.0.0.0. You would also add any other networks such as the 10.10.x.0/24 networks to this ospf area. The ospf link-type of point-to-point is used for point to point connections. The passive type is for networks that will not connect to any other ospf areas. The default for Cisco is a type called broadcast.
configure ospf routerid 1.1.1.1
configure ospf add vlan p2pToCisco area 0.0.0.0 link-type point-to-point
configure ospf vlan p2pToCisco priority 0
configure ospf vlan (OtherVlans) area 0.0.0.0 passive
enable ospf
To verify configuration you can run the commands
show iproute, show ospf, and show ospf lsdb detail
On the Cisco side which will be doing the route redistribution the configuration is as follows.
On the VLAN interface you must set the ospf network type to point to point by default when you create the ospf router this will have an ospf type of broadcast. With that you will see the Cisco and the Extreme create an OSPF Full peer status and using when looking at the link state database you may see the networks but they will not enter the routing table.
interface Vlan302
description Interface for point to point to
Extreme
ip address 172.31.1.1 255.255.255.252
ip ospf network point-to-point
!
On the EIGRP router you need to redistribute the routes into OSPF like the following example.
router eigrp 101
network 169.254.10.32 0.0.0.31
redistribute ospf 1 metric 1500 10 255 1 1500
eigrp stub connected summary redistributed
!
On the OSPF router you also need to redistribute the EIGRP routes but you need to create a route-map filter to keep the summary addresses that OSPF feeds into EIGRP from being redistributed back into OSPF creating a routing loop.
To create a route-map match list preventing 10.0.0.0/8 summaries from being reinjected into the route table use the following.
ip prefix-list
eigrp-to-ospf seq 5 deny 10.0.0.0/8
ip prefix-list
eigrp-to-ospf seq 10 permit 0.0.0.0/0 le 32
route-map
eigrp-to-ospf permit 10
match ip address prefix-list eigrp-to-ospf
The following is what the OSPF router configuration would look like
router ospf 1
log-adjacency-changes
redistribute eigrp 101 metric-type 1 subnets
route-map eigrp-to-ospf
network 172.31.1.0 0.0.0.3 area 0.0.0.0
!
Finally the following configuration will set the cisco interface to be a trunk to match the Extreme tagged VLAN.
interface GigabitEthernet1/0/1
description Uplink to Extreme 1:1
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport mode trunk
!
No comments:
Post a Comment